---
title: "Invoice Stuck in Pending Status After Batch Export"
slug: "invoice-stuck-in-pending-status-after-batch-export"
updated: 2026-03-27T01:43:21Z
published: 2026-03-27T01:43:21Z
---

> ## Documentation Index
> Fetch the complete documentation index at: https://help.servicetitan.com/llms.txt
> Use this file to discover all available pages before exploring further.

# Invoice Stuck in Pending Status After Batch Export

## Problem

An invoice is displayed as *Pending* in an exported batch and cannot be unposted or re-exported. The batch itself shows as successfully exported.

## Root causes

- Customer deposts may not be properly mapped between ServiceTitan and your accounting software
- You changed your inventory tracking settings after the invoice was created
- You have incorrectly named GL accounts or missing accounts
- You have extra spaces in customer names or missing customer ID numbers

## Solution

1. Try to un-post, re-post, and export the batch.
2. If the invoice is still in *Pending* status, add the invoice to a new batch and try to export it.
3. If the invoice is still in *Pending* status, verify that the invoice or payment is not in your accounting software by searching for it and getting a visual example or screenshot showing no results.
4. If the invoice or payment is not in your accounting software, contact [Technical Support](http://go.servicetitan.com/ask) and have them unlock the batch associated with the invoice then try to export it.

### Additional troubleshooting

- Check for missing batch numbers.
- Verify jobs are properly completed before batching. Incomplete jobs prevent exporting.
- Check for overlapping timesheets.
- Check for missing invoice dates on adjustment invoices.
- Verify that your GL account ntames match exactly between ServiceTitan and accounting software.
- Check for inactive items in your accounting software. For example, check for *Object Not Found* errors.
- Verify that your business units are mapped correctly with your accounting software.
